View Single Post
Old 11-10-2014, 12:00 AM   #91
H311RA151N
Silver Member
 
Join Date: Jun 2012
Location: Oasis, Iowa
Posts: 2,347
H311RA151N seems to have made some friends! H311RA151N seems to have made some friends!
The bad.

Where do I start...

I'm wore out. Too busy and nothing is going right. Or at least the things I'm stressed the most about anyways.

I dropped the rear tank today. Only to find Oreilly's sold me the wrong fuel pump assembly and they cannot get the right one. Neither can NAPA or Autozone.

The brass float was full of fuel from a pinhole is the reason for the fuel level sending unit not working. The gauge will move when I plug the assembly in and move the arm.

I tried brazing the float to fix the pinhole but with the fuel vapors inside and the heat it kept making a little hole in the solder. I tried so many times I ruined the float.

I just wanted to buy a new float and use the old pump and assembly but I cannot find any online at Autozone, NAPA, or Oreilly's.

I have thought about using something else that will float but nothing comes to mind. Other than cork which wont work.

So here are the pictures of this nightmare.




The good.

I tightened the rear pinion nut down to 140ftlbs which is what Ford calls for. It was 1 and 1/4 turns loose. Not a bit of slop what so ever now that it's tightened. So that's good. U-joint is good so I didn't replace it.





And I got the new heater core in. No pics of it installed but here is the old one.



__________________
Quote:
Originally Posted by gloryaccordy View Post
Holy fuck, it's the weekend man.

Last edited by H311RA151N; 12-11-2014 at 08:09 PM.
H311RA151N is offline   Reply With Quote