Announcement

Collapse
No announcement yet.

TSX Troubles... Navigation Screen Clock Reads 00:00

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hiptech
    replied
    Couldn't agree with you more!

    It used to be called "planned obsolescence" back in the day. It's just a tough pill to swallow for those of us who take care of our cars and like everything to work...

    Leave a comment:


  • Raf99
    replied
    I have an Audi A4 B9 (2017 - 2019). In 2020 Audi ditched their Audi Connect which allows google maps + real time data / traffic etc, etc. (ditched their service provider connection via certain model of entertainment system). All other live maps (3rd party, google, apple, etc.) won't work on the virtual cockpit. Audi says "too bad, so sad" and only their new 2021 vehicles have the new computer that can make a connection to the satellite for real-time updates. I'd imagine if you buy a 2021 in 3-5 years they'll ditch (move on) to another new tech, leaving users helpless. So at least your TSX only messes up the clock (thankfully the engineer who designed it hard coded it to a satellite connection that would exist in 20 years but now has "bugs"), newer cars take away full functionality (GPS, live data, sirius, etc. ). Tesla simply disables stuff because you didn't pay. Pretty soon it will be live payment (want your radio to work? Pay $29.95 a year). Sad really.

    Leave a comment:


  • hiptech
    replied
    Whatever the case I'd love to speak with a genuine Honda engineer instead of an Acura CSA and find out the real truth to this. Though after this many years I'm inclined to believe they've abandoned any resources to it.

    See boys and girls... this is what inevitably happens to all your expensive tech toys car makers love to force (and charge big $$$) on you. It's barely new when you buy it, obsolete by the time you get it home and defective beyond repair when it fails.

    Even before this happened I stopped using the navi years ago due to it's inability to upgrade. And honestly, if I could have predicted how soon it would be rendered useless I could have saved an extra $2k!

    Leave a comment:


  • Raf99
    replied
    Ya, I still miss my TSX but I did not have the GPS. And from what I read/know it was a GPS rollover bug. Y2K type stuff, but really just a really old ROMs & satellite. Nothing can be done as the date/time was hard-coded (ROM & not EPROM :P ). Affects a lot of models and obviously nothing Honda is going to do. Those with older ROM/firmware had to upgrade via a disc, and some "weird" affects were seen if you didn't upgrade. IE: some had an issue after battery disconnect, and some did not. One guy summed it up on a random site...

    "How the end of the second GPS epoch will manifest on specific devices is completely dependent on how the manufacturer coded the thing. Some will interpret the rollover as a 19.7 year leap in time, either backward or forward. Navigation itself should not be impacted, even if the time goes wonky, or just for a moment if it does. Non-navigational GPS receivers, like the GPS time bases used to synchronize cell phone services, might have more of an issue, but again, if the devices are of recent vintage or have been patched, there shouldn’t be an issue."

    One guy on the forums you posted said he got his working with a new ROM chip. Ouch. I'd say get the DVD reloaded on there to get the latest firmware, park on top of a mountain for 8 hours and cross your fingers. Some devices don't give the option to load / reload the ROM/Firmware (garmin, etc.) and soon Acura / Honda may be in this spot. IE: Randy who wrote the ROM chips died 8 years ago or they simply don't care (no $$$).

    Leave a comment:


  • hiptech
    started a topic TSX Troubles... Navigation Screen Clock Reads 00:00

    TSX Troubles... Navigation Screen Clock Reads 00:00

    Anyone heard of this? Up until recently I hadn't. Turns out this is well documented problem that's been around for more than 5 years but seems to have flown under the radar unless you've been afffected. Sadly it plaques a variety of Hondas & Acuras models and crosses a wide range of years. The worst part is Honda is well aware of this issue but either seems to have ignored it or is truly stumped.

    Let me start from the beginning...

    Everything was working well with my TSX up until about 3 weeks ago when my 2-1/2 year old battery failed and left me stranded at the supermarket due to a bad cell. I called AAA and they quickly diagnosed a failed cell. Since the battery had a few months left on it's 36 month warranty I elected to let them charge it and I immediately drove about 5 miles home. A few days later I installed and connected a new battery, reset the Navi and radio codes, started it up and all seemed well. It wasn't until the following day I noticed the clock at the top center of the dash was way off. On Navi equipped models this automagically sets through GPS signal. My first thought was that I did something wrong since onscreen instructions state the car needs to be running standing still for about 10 minutes and away from any buildings. I did the codes but didn't pull it out from the garage to let it run long enough.

    So I drove it out to the street, disconnected the battery, waited about 10 minutes, reconnected it and reprogrammed the codes and let it run as per directions. Still no luck. I tried this again multiple times even connecting both the positive and negative cables together after waiting several minutes to ensure any capacitors would be fully discharged. No luck either.

    Next I tried to manually override the clock settings manually using the navigation manual override controls - no response. The funny thing is that while the clocks didn't function they do display differently. The navigation screen shows 00:00 while the upper dash clock usually starts at 1:00 from the time the battery is reconnected. I've read where many people try to synchronize the battery reconnection with the current time of day at precisely 1:00 and I may do this as an ultimate hail Mary.

    I moved the car back into the garage and took some time to research the issue. Immediately a number of usergroup forums for various Hondas and Acuras showed this be a very old persistent issue with only a few solutions. One mentioned to precisely reconnect the battery with the time of day in an effort to regain some clock accuracy. Curiously the other involved changing out the Navi DVD back to the original. As I understand it the navigation not only derives the map and POIs from the disk but also boots from it as well. There seems to be a theory that something refereed to "GPS epoch" event may be responsible. In some cases several people reported this issue actually corrected itself though it may have taken months or years before doing so.

    Here is a definition of the GPS epoch:

    "GPS Epoch is a continuous time system for all satellites and observation systems. It is represented in seconds since Jan 5, 1980 (presumably when GNSS went online). It is measured as the average of the atomic clocks for the observations and satellites - the accuracy of positioning depends on the precise timing accurate to better than two nanoseconds, given the speeds the satellites are traveling.

    The time is represented as a week number (starting Saturday night at midnight), and seconds in week. Thus the seconds count can reach 604,800 then roll to zero. Because the number is 10bit data, when the weeks hit 1023 (210 - 1) they then roll back to zero (this happened in 1999 for the first time).

    GPS epoch doesn’t adjust for leap seconds, so is 16 seconds ahead of current UTC time (and growing over time)."


    If this is epoch event is responsible or not I don't know. But the belief is by rebooting the navigation system from the original disk it somehow can fix it. While I did upgrade my disk back in '08 I can't for the life of me find the original! In any case I've put together a list of threads from various forums discussing the issue along with a link to the Honda Tech Line Summary Article and even a USAToday article from back in Aug 2017 talking about how they were trying to find a fix for this! Yet when I called Acura customer service they acted as if they knew nothing about it. They did document my call, assigned me a case number and said "a case manager would review my issue and call back." That was on 09/24, no one has called.

    Ironically through all this the Navi system still operates normally which I rarely use anymore. It's the clock I frequently use.


    There's much more including YT vids if you use the search term:
    "Navigation Screen Clock Reads 00:00"


    Otherwise here are some links to other discussions involving this issue.

    Honda Tech Line Summary Article: Sept 2017
    Navigation Screen Clock Reads 00:00
    http://www.urvi.net/forumfiles/SB/ATS170802.PDF

    What is a GPS epoch?
    https://gis.stackexchange.com/questi...t-is-gps-epoch

    USAToday Article: Crazy time: Clocks in older Hondas reset themselves to 00:00
    https://www.usatoday.com/story/money...-00/605519001/

    2004 TSX can't set clock | Acura TSX Forum
    https://www.tsxclub.com/threads/2004...-clock.196142/

    2005 TSX - unable to change time on digital clock (above navi) | Acura TSX Forum
    https://www.tsxclub.com/threads/2005-tsx-unable-to-change-time-on-digital-clock-above-navi.195953/

    2005 TL Clock and Nav issues | Acura World
    https://www.acuraworld.com/threads/2...-issues.96849/

    2004 Accord with Navigation: cannot set clock to correct time after disconnecting/replacing battery | Drive Accord Honda Forums
    https://www.driveaccord.net/threads/...attery.556246/

    Clock stuck to 0:00, navi/GPS working fine | Acura MDX SUV Forums
    https://www.driveaccord.net/threads/...attery.556246/




    So at this point I'm stuck waiting to figure this out. Maybe someone here has experience with this or know someone who has if so I'm anxious to hear of how they resolved it...
    If only all cars were as reliable as the CB7s!


    Here's pic showing the clock at the upper right side of the display indicating an arbitrary time of 10:10 while the Navi screen shows 00:00





    Last edited by hiptech; 10-08-2021, 07:35 PM.
Working...
X