Announcement

Collapse
No announcement yet.

Intermittent Transmission Shifting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Intermittent Transmission Shifting

    Prior to changing the Transmission Solenoids and changing out the Transmission Oil with Honda AT Oil, during a hot day and city driving, my 93 LX auto was shifting into 3rd gear in high RPMs. Also, prior, it was still shifting down and up to 1st, 2, 3 (high rpms), 4th and Torque Converter knudge. A few days ago, i noticed it stopped feeling the torque converter knudge. I have read the FAQ and it doesn't quite have my problem. soo, I have changed out the tranny oil, and tranny solenoid. Has anyone experienced the same problem? Before i dig out the TCU, should i try some other fix? Last thing, prior to changing the upper solenoid (i forget the name of it.) my CB7 was shifting to the 5th, and when i changed the solenoid, the torque converter locked/unlocked BUT now it is not.

    I have done the following to recap:
    1. Change transmission oil <500 miles ago
    2. Change both solenoids

    I have the below questions:
    1. Should i remove the remanufactured upper solenoid and install the original?
    2. Should i just dig out the TCU and repair it OR replace the whole thing. Money is not a problem to buy a repair TCU. I just don't have the knowledge to visually check the TCU IF there are other resisters or capacitors are bad.
    3. If i go to a JY, can i use any TCU from any CB7 family? but if i did that, how would i know if that TCU is bad.
    4. If i mustered enough energy to do the fix myself on the TCU, any suggestions where i can buy a TCU repair kit (new resistors and capacitors)
    5. If i want to buy a whole remanufacturered TCU, any suggestions where to buy one from?

    i don't want to give up on the "White Ghost" BUT i will if the shifting gets uglier. HELP please.
    Last edited by ca93accord; 08-30-2021, 12:17 AM.

    #2
    The transmission is only four speeds; what you're feeling as "fifth" is the torque converter locking and unlocking. How did you change the fluid, just one drain and refill? If you have no idea how long it has been since the fluid was changed prior to that, I suggest two more drain and refills so you have approximately 80% new fluid. Did you mess with the throttle cable to the transmission?

    There are different TCUs depending on the engine. Go to www.hondaautomotiveparts.com to determine the correct part number for your vehicle.

    I used seller "mandigital" on ebay to repair two TCUs with no problems for several years before I sold the vehicles. $75 with lifetime guarantee.
    90 LX 4dr 5 spd 395,000 - MRT: http://www.cb7tuner.com/vbb/showthread.php?t=201450
    07 Element EX AWD 203,000 - MRT: http://www.cb7tuner.com/vbb/showthread.php?t=210623
    07 Element EX AWD AT (2) 98,000 - MRT: www.cb7tuner.com/vbb/showthread.php?t=211920
    08 Element LX FWD AT 225,000 - MRT: fleetw00d : 2008 Honda Element LX - CB7Tuner Forums
    LOTS of CB7 parts - ENTIRE COLLECTION - FREE
    Come and get it. http://www.cb7tuner.com/vbb/showthread.php?t=192583

    Comment


      #3
      Fleetwood,
      I was hoping a CB7 Jedi would have helped me. thanks for your help.

      LOL. i sounded stupid about the 5th gear. LOL. anyways, thank you soo much for you insight. I will change the tranny oil a couple more times. thanks. BTW, i didn't mess with the throttle cable. I will post any changes ASAP.

      Comment


        #4
        Fleetwood or anyone with more knowledge than me,
        So I have changed out the AT fluid 3 times. Once a month-ish ago, and today twice. This is the results:
        1. It shifts 1st to 4th
        2. Going into 3rd, i still get the high RPM shift.
        3. I don't feel the Torque Converter (TC) locking up (knudge).

        Prior to this post, i have removed and replaced both solenoids because i was getting the high RPM shift into 3rd. i thought it would have fixed it. Prior to the solenoid change, the TC was locking up. I changed it because the solenoid came in as a set. I bought it from Amazon. When i replaced the solenoid, it was driving better and it seemed faster at idle. the TC did lock up but as i drove it around town with the stop and go town driving, the high rpm into 3rd occured and i noticed the TC wasn't locking up. In the morning, first start up and drive, the TC will most likely lock up. when it is normal operating temp, and city driving, the problems are noticed.

        Should i put back both the original solenoids? should i just replace the lock up solenoid? should i JUST buy a TCU repair kit from ebay and tackle that project to repair the TCU?

        Comment


          #5
          This morning, I believe I went into limp mode but idk. This is what happened. I live on a military base where 30 MPH is the norm. With the stop and go, I was coming to a stop and it down shifted weird. When the light turned green, I gave it some gas and it was stuck in a gear. Idk which gear probably maybe 1st. I manually shifted my selector handle to 2nd. Then it started shifting normal. Ugh. I need help. I am only the 2nd owner and original automatic transmission.

          Could it be a bad TCU?

          Comment


            #6
            With all the noticeable problems, I do not have any blinking d4 nor check engine light. It is solid.

            Comment


              #7
              i have noticed that when the problems occur, my ride is at normal operating temp. when i park to go to work, it sits for about 7-8 hours. when i drive home, which it about 5 min drive home, the 3rd high rpm shift is not there.

              Comment


                #8
                Are you saying that your D4 light is on solid all the time regardless of the position of the shift lever? If so, then you've got at least one code set; worst case your TCU needs repair. You can get the codes the same way you read the check engine codes.
                90 LX 4dr 5 spd 395,000 - MRT: http://www.cb7tuner.com/vbb/showthread.php?t=201450
                07 Element EX AWD 203,000 - MRT: http://www.cb7tuner.com/vbb/showthread.php?t=210623
                07 Element EX AWD AT (2) 98,000 - MRT: www.cb7tuner.com/vbb/showthread.php?t=211920
                08 Element LX FWD AT 225,000 - MRT: fleetw00d : 2008 Honda Element LX - CB7Tuner Forums
                LOTS of CB7 parts - ENTIRE COLLECTION - FREE
                Come and get it. http://www.cb7tuner.com/vbb/showthread.php?t=192583

                Comment


                  #9
                  When I select it to a different gear, d4 light turns off and respective gear light turns on.

                  Comment


                    #10
                    I have read other forums and I am planning to put back the original lock up solenoid and change out the thermostat.

                    Comment


                      #11
                      This sounds like bad torque converter or an internal mechanical issue.
                      Under Construction​​​​​​​​

                      Comment


                        #12
                        Today, I was able to feel the nudge of the torque converte locking up. No high rpm shift into 3rd. I have not changed out the thermostat. I will soon though

                        Comment


                          #13
                          If it's a bad torque converter, will it NOT lock up everything. Earlier today, it locked up. It always happens on the first drive. 15 mins into town to pick up my kids. On the way back, I don't feel the torque converter locking up.

                          I still haven't changed my thermostat and reinstall my original lock up solenoid.

                          Could those help?

                          Comment

                          Working...
                          X