Announcement

Collapse
No announcement yet.

Is my 1990 Honda Accord LX fuel pump failing?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad_dude
    replied
    It’s weird, once the car cools down, no more gas smell from the area. I would think if there was a leak it would smell all the time.

    Leave a comment:


  • Fleetw00d
    replied
    Check the fill pipe for rust and the fuel lines from the tank (there is a plastic cover just inboard from the left rear wheel. These lines can tend to rust and leak.

    Leave a comment:


  • Bad_dude
    replied
    I have narrowed it down to the gas cap area. I already just got a new gas cap from Walmart and still smell gas from here. Is it a defective cap or could it be something else that is wrong in this area? Thanks for the help.

    Leave a comment:


  • Fleetw00d
    replied
    The pump isn't failing, the electronics that power it are. To the best of my knowledge, the pump shouldn't run on it's own after shutting off the car. Are you sure it is the pump? The fans can turn on for a while after shutting the engine off.

    The balance shafts are there to reduce vibration. The automatic transmission cars have an active rear engine mount; it has a valve that connects fluid chambers on the top and bottom of the mount. At idle, the valve is open to soften the mount to reduce vibration transmitted to the car. Above idle, the valve closes to stiffen the mount for normal driving. If the mount is still original - it likely isn't working anymore but I would expect it to fail soft.

    My wagon shook more than any other automatic Accord I had - I replaced the rear mount, double checked balance shaft timing, other mounts; it improved, but never got as smooth as others I've owned.
    Last edited by Fleetw00d; 10-26-2021, 08:32 PM.

    Leave a comment:


  • Bad_dude
    started a topic Is my 1990 Honda Accord LX fuel pump failing?

    Is my 1990 Honda Accord LX fuel pump failing?

    I noticed now after I park my CB, the fuel pump still going on and off like morning priming. This happens when the fuel tank down from 3/4 tank or less. This occurs every time after I park in my garage. It also has a faint smell of fuel. After about 5 minutes or less the pump stops. The car performance doesn’t change and still runs well. No problem on the freeway or speeding up. The car just now has 207,000 miles on it. Idle is perfect at 750 rpm and automatic transmission. I have replaced the original Honda gas cap with a standard black Walmart cap.

    Another note which has nothing to do with the fuel pump. This has been happening since I got the car back in 2008 with 136,000 miles. At a red light or stop signs, at good idle, the steering wheels shakes a little. Nothing violent. My mechanic said these cars do this when it gets old due to the balancer shaft. I wonder if this is the real reason. If anyone could point out how to fix this shake.

    Thanks.
    Last edited by Bad_dude; 10-09-2021, 10:31 PM.
Working...
X