CB7Tuner Forums

Go Back   CB7Tuner Forums > Beginner forum -- New members post here! > Beginner Technical/Performance

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-09-2011, 08:14 PM   #1
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
EGR Hose not connected

I just failed emissions and went to check my O2 sensor and EGR, the O2 seems to be fine. Then I was going to clean my EGR, but before I disconnected it, I noticed the hose is not there, I think this might be the cause of my problem. This is on an H22A if that matters.

My question is where am I supposed to connect this to? The part coming out on the right side is what I'm talking about.



Also my idle is low and the car does die after hard acceleration so it definately seems like this should be the issue, however if this does not bring my idle up enough, if someone could show me which screw I turn on the throttle body to adjust the idle I'd appreciate that.

Thanks in advance for your help.
Boredumb is offline   Reply With Quote
Old 06-09-2011, 08:32 PM   #2
559cb7559
Newcomer
 
Join Date: Dec 2010
Location: CA
Posts: 22
559cb7559 is cool... so far.
yeah disconnected egr would cause it to fail smog
559cb7559 is offline   Reply With Quote
Old 06-09-2011, 08:46 PM   #3
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
Thanks. I assumed as much. Just figured out how to adjust the idle on the throttle body. Still need to know where that hose is supposed to connect to.
Boredumb is offline   Reply With Quote
Old 06-09-2011, 08:51 PM   #4
djcaz_aom
Contributing Member
 
Join Date: Sep 2006
Location: USA/ Puerto Rico
Posts: 2,424
djcaz_aom seems to have made some friends! djcaz_aom seems to have made some friends!
It goes to the black box on the firewall.

It is hose #16. It goes to the EGR control solenoid.
djcaz_aom is offline   Reply With Quote
Old 06-10-2011, 05:16 PM   #5
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
I think my egr solenoid might be missing altogether. Could someone take a pic of theirs so I can see exactly what I should be looking for?.
Boredumb is offline   Reply With Quote
Old 06-10-2011, 07:19 PM   #6
madmattr6
Newcomer
 
Join Date: May 2011
Location: pomona
Posts: 25
madmattr6 is cool... so far.
Its a rubber hose that your missing...it either connects to the vacuum box or the manifold..that missing hose can cause ur engine to die since you have a vacuum leak..im guessing you failed the smog test either because you had a check engine light or high nox....right?
madmattr6 is offline   Reply With Quote
Old 06-10-2011, 08:20 PM   #7
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
Quote:
Originally Posted by madmattr6 View Post
Its a rubber hose that your missing...it either connects to the vacuum box or the manifold..that missing hose can cause ur engine to die since you have a vacuum leak..im guessing you failed the smog test either because you had a check engine light or high nox....right?
No check engine light. It was High Carbon Monoxide that caused me to fail.

When you say it either connects to the vacuum box or the manifold, do you mean it can connect to wherever?
Boredumb is offline   Reply With Quote
Old 06-10-2011, 09:08 PM   #8
coupes
CB7tuner Member
 
Join Date: Apr 2011
Posts: 289
coupes is cool... so far.
Quote:
Originally Posted by Boredumb View Post
No check engine light. It was High Carbon Monoxide that caused me to fail.

When you say it either connects to the vacuum box or the manifold, do you mean it can connect to wherever?
Nope..... the black box on the firewall above the charcoal canister should have 3 hoses coming out the bottom..... the one marked 16 should go to the egr although in may be too short to reach the prelude egr......
coupes is offline   Reply With Quote
Old 06-10-2011, 09:54 PM   #9
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
Quote:
Originally Posted by coupes View Post
Nope..... the black box on the firewall above the charcoal canister should have 3 hoses coming out the bottom..... the one marked 16 should go to the egr although in may be too short to reach the prelude egr......
I think I might be missing this box? Do you know a part number for it?
Boredumb is offline   Reply With Quote
Old 06-10-2011, 10:09 PM   #10
coupes
CB7tuner Member
 
Join Date: Apr 2011
Posts: 289
coupes is cool... so far.
Quote:
Originally Posted by Boredumb View Post
I think I might be missing this box? Do you know a part number for it?
I can get you a part number but you're better off going to the jy for that....... it's on the passenger side on the firewall

coupes is offline   Reply With Quote
Old 06-10-2011, 10:15 PM   #11
Boredumb
Newcomer
 
Join Date: Feb 2010
Posts: 21
Boredumb is cool... so far.
Alright yea. I'm missing that whole thing. Thanks a lot for the picture. I'll check some junkyards this weekend.
Boredumb is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.