Announcement

Collapse
1 of 2 < >

ANY BUYING/SELLING IN THIS FORUM WILL RESULT IN AN INSTANT BAN!

Read the rules: http://www.cb7tuner.com/vbb/showthread.php?t=43956

Myself, and the other mods have been very nice and lenient with the rules. We have been deleting threads, and giving out warnings. Some members didn't get the clue and re-posted over and over... Now ANY member buying or selling in this section will be banned... No IF's AND's or BUT's.
2 of 2 < >

Beginner Forum Rules - EVERYBODY read! (old and new members alike!)

Beginners start here. Once you have 30 worthwhile posts (off topic doesn't count) you may post outside of the Beginner forums. Any "whoring" (posting simply to raise your post count) will return your count to 0, or result in a ban.

These are the rules. Read them. Live by them.

1) Absolutely NO flaming! "Flaming" is an outright attack on a member. ALL questions are encouraged to be asked here, no matter how basic. Members with over 30 posts will be subject to a ONE WEEK ban if caught flaming in this forum (and yes, moderators can read deleted posts). Members with under 30 posts will be subject to a ONE DAY ban.

2) Use appropriate language. Racial or sexual slurs will not be tolerated. A ban will be issued at the discretion of the cb7tuner.com staff.

3) No items may be sold in the Beginner forums. Any "for sale" threads will be deleted.

4) Temporarily banned members will be PERMANTLY banned if they are found posting on another account.

The rules can and will be added to. Any updates will be marked in the title.

The rules for the overall forum can be found here:
http://www.cb7tuner.com/vbb/forumdisplay.php?f=144
Read them. You will be expected to follow them.
See more
See less

Throwing Multiple CEL(s)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Throwing Multiple CEL(s)

    I am trying to diagnose my CEL(s). It is a bunch of codes thrown at once when driving at freeway speeds for ~5 miles. CEL is never thrown when I am driving around town for reference.

    Codes: 43, 1, 7, 20. These are a lot of codes that I never had before. We can see it's a Fuel System code, O2 Sensor, TPS, and Electrical load detector. These don't seem connected to my understanding of the fuel system. I tried replacing the Main Relay but I still throw the CEL with the same codes. I don't think it's the O2 sensor because it is relatively new from when I threw a code 41 about a year ago.

    Some background info is that this started happening after I had my kill switch tied to my fuel pump disconnect (the wire was not soldiered properly) and it kept clicking the relay on and off. Maybe it damaged something else down the line? I am not really sure where to go with this, or where to start.

    Let me know if you have any suggestions to tackle this issue. Ill continue to research in the meantime.

    #2
    UPDATE:

    Took a gander at the TPS plug, looks like there is evidence of a short. This explains the TPS code.
    Click image for larger version

Name:	Screenshot 2024-02-05 203439.jpg
Views:	25
Size:	24.0 KB
ID:	4984747

    Comment

    Working...
    X